HDOJ 1005 Number Sequence(规律)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 127173    Accepted Submission(s): 30910


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1012  1108  1071  1006  1007 
 
不找循环长度的AC:
#include<stdio.h>
int main()
{
	int i,n,A,B;
	int f[100],num;
	while(scanf("%d%d%d",&A,&B,&n)!=EOF && (A || B || n)){
		f[1] = 1;
		f[2] = 1;
		for(i=3; i<=99; i++){
			f[i] = (A * f[i-1] + B * f[i-2]) % 7;
			if(f[i] == f[i-1] && f[i] == 1) //判断是否出现周期
				break;
		}
		num = i-2;
		n = n % num;
		if( n == 0)
			printf("%d\n",f[num]);
		else
			printf("%d\n",f[n]);
	}
	return 0;
}


循环长度49:对于公式 f[n] = A * f[n-1] + B * f[n-2]; 后者只有7 * 7 = 49 种可能,为什么这么说,因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。
#include<stdio.h>

int fun(int a,int b,__int64 n){
	if(n==1||n==2) return 1;
	else return(a*fun(a,b,n-1)+b*fun(a,b,n-2))%7;
}
int main(){
	int a,b;
	__int64 n;
	while(scanf("%d%d%I64d",&a,&b,&n)&&(a||b||n)){
		printf("%d\n",fun(a,b,n%49));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值