高精度乘法

a*b
Time Limit: 1sec    Memory Limit:32MB
Description

Give two positive integers a and b, please help us calculate a*b.

Input

The first line of the input is a positive integer T. T is the number of test cases followed.

Each test case contain two integer a,b (0<=a<=10^100, 0<=b<=10,000) given in one line.

Output

The output of each test case should consist of one line, contain the result of a*b.

Sample Input
 Copy sample input to clipboard
12 7
Sample Output
14


a为一个大数 ,b为一个int数
所以a需要用字符串表示,b用int表示即可
#include <iostream>
#include <cstring>
#include <memory>
using namespace std;
int main() {
    int T;
    cin >> T;
    while(T--) {
        string a;
        int b;
        cin >> a >> b;
        int num[101];
        int result[120];
       // cout <<a<<endl;
        int alength = a.length();
      // cout << "alen" << alength <<endl;
        memset(result,0,sizeof(result));
        for(int i = 0;i < alength;i ++) {
              num[alength - i - 1] = a[i] - '0';
             // cout <<"dd:"<< a[i];
        }
        
        int carry = 0;
        for(int i = 0;i < alength;i ++) {
            result[i] = num[i] * b + carry;
            carry  = result[i]/10;
            result[i] %= 10;
            
        }
        result[alength] = carry;
        int resultlen = alength + 6;
        while(result[resultlen]==0 && resultlen >= 0) {
            resultlen --;
        }
        //cout << resultlen << endl;
        if(resultlen < 0)
            cout << "0" << endl;
        else {
            for(int i = resultlen;i >= 0;i --) {
                cout << result[i];
            }
            cout << endl;
        }
        
    }
    return 0;
}
        



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值