Sorting It All Out(拓扑排序)

ACM-ICPC亚洲区预选赛(北京赛区)游戏对抗邀请赛​正在报名中
Language:
Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33626 Accepted: 11753

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source


这题典型的拓扑排序,但是有点变化。
题目样例的三种输出分别是:
1. 在第x个关系中可以唯一的确定排序,并输出。
2. 在第x个关系中发现了有回环(Inconsisitency矛盾)
3.全部关系都没有发现上面两种情况,输出第3种.


那么对于给定的m个关系,一个个的读进去,每读进去一次就要进行一次拓扑排序,如果发现情况1和情况2,那么就不用再考虑后面的那些关系了,但是还要继续读完后面的关系(但不处理)。如果读完了所有关系,还没有出现情况1和情况2,那么就输出情况3.
拓扑排序有两种方法,一种是算法导论上的,一种是用贪心的思想,这题用贪心的思想做更好。


贪心的做法:
1. 找到所有入度为0的点, 加入队列Q
2.取出队列Q的一个点,把以这个点为起点,所有它的终点的入度都减1. 如果这个过程中发现经过减1后入度变为0的,把这个点加入队列Q。
3.重复步骤2,直到Q为空。


这个过程中,如果同时有多个点的入度为0,说明不能唯一确定关系。
如果结束之后,所得到的经过排序的点少于点的总数,那么说明有回环。




题目还需要注意的一点:如果边(u,v)之前已经输入过了,那么之后这条边都不再加入。

#include <iostream>
#include <cstdio>
#include <stack>
#include <cstdlib>
#include <cstring>
using namespace std;
int n,m;
int mp[110][110],in[110],list[110],tm[110];//list数组存储输出的字母,mp[i][j]=1则存在关系且i<j
int toopsort()
{
    stack<int>s;
    while(!s.empty())
    {
       s.pop();
    }
    int flag=0,j=0;
    memcpy(tm,in,sizeof(in));
    for(int i=0;i<n;i++)
    {
        if(tm[i]==0)
        {
          s.push(i);//找出入度为0得点即为起始点
        }
    }
    while(!s.empty())
    {
         if(s.size()>1)//如果入度为零得点有很多,则很多点还没涉及到还处于初始化中,为1时才只有一个起始点
         {
            flag=1;//不能确定关系则要继续进行
         }
         int t=s.top();
         s.pop();
         list[j++]=t;
         for(int i=0;i<n;i++)
         {
            if(mp[t][i])//t和i有关系
            {
               if(--tm[i]==0)//存储入度为0得点
               {
                  s.push(i);
               }
            }
         }

    }
    if(j!=n)//如果j>n则说明有环,应为处理完后加上初始化的入度为0得点应为n个
    return 1;
    else if(flag)//无法确定关系继续
    return 2;
    else return 0;//既没有环又没有不能确定关系的则完成
}
int main()
{
    int flag1,flag2;
    char x,y;
    while(~scanf("%d%d",&n,&m)&&n&&m)
    {
          getchar();
          flag1=0;
          flag2=0;
          memset(mp,0,sizeof(mp));
          memset(in,0,sizeof(in));
          for(int i=1;i<=m;i++)
          {
          scanf("%c<%c",&x,&y);//即使有了结果也要保证全部输入完成
          getchar();
          if(!flag1&&!flag2)//用两个标记变量来确定
          {


               if(mp[y-'A'][x-'A']==1)//xY和Yx都有
               {
                  printf("Inconsistency found after %d relations.",i);
                  flag1=1;
                  continue;
               }
               if(mp[x-'A'][y-'A']==0)
               {
                  mp[x-'A'][y-'A']=1;
                  in[y-'A']++;
               }
               int tmp=toopsort();
               if(tmp==1)
               {
                  printf("Inconsistency found after %d relations.",i);
                  flag1=1;
               }
               else if(tmp==0)
               {
                  flag2=1;
                  printf("Sorted sequence determined after %d relations: ",i);
                  for(int j=0;j<n;j++)
                  {
                     printf("%c",list[j]+'A');
                  }
                  printf(".");
               }
          }

          }
          if(!flag1&&!flag2)//剩下的情况就是无法判定了
          {
          printf("Sorted sequence cannot be determined.");
          }
          printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值