11 快速取模

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their
cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this
market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into
the KOKODDáKH. The rules follow:
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given
moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all
players including oneself and determine the remainder after division by a given number M. The winner is the one who first
determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing
higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
输入
The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first
line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000).
The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines
follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at
the same time.
输出
For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
(A1B1 + A2B2 + ... + AHBH) mod M.
样例输入
3
16
42 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132
样例输出
2
13195
13

描述

快速取模运算,可以将O(n)的复杂度降低到O(log(n))

代码

#include<cstdio>
using namespace std;

#define LL long long

LL quick(LL a,LL b,LL m){//a^b%m
	LL ans=1;
	while(b){//当b是奇数
		if(b&1){
			ans = ans * a % m; 
		}
		b>>=1;
		a = a*a%m;
	}
	return ans;
}
//LL multi(LL a,LL b,LL m){//a*b%m
//	LL ans=0;
//	while(b){
//		if(b&1){
//			ans = (ans + a) %m;
//		}
//		b>>=1;
//		a = (a+a)%m;
//	}
//	return ans;
//}
int main(){
	int z,m,h;
	LL ai,bi;
	LL ans;
	scanf("%d",&z);
	while(z--){
		ans=0;
		scanf("%d",&m);
		scanf("%d",&h);
		for(int i=0;i<h;i++){
			scanf("%lld%lld",&ai,&bi);
			ans += quick(ai,bi,m);
		}
		ans = ans%m;
		printf("%lld\n",ans);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值