[DP]HOJ 1058Number Triangles

传送门:Number Triangles

Number Triangles

My Tags  (Edit)
  Source : USACO Gateway
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 2361, Accepted : 912

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

There are multiple testcases, process to the end of file.

SAMPLE INPUT
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT
30 


解题报告:

此题可以使用搜索来做,但是耗时,更简单的方法是动态规划(DP),这题是经典的方格取数问题。

首先我们设f[i][j]取到的是第i行第j列的最大数字,发现f[i][j]只与f[i-1][j]和f[i-1][j-1]有关。于是容易得出:

f[i][j]=Matrix[i][j]+max(f[i-1][j],f[i-1][j-1])。代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int Matrix[1002][1002];
int f[1002][1002];
int main(){
    int r;
    while(scanf("%d",&r)==1){
        memset(Matrix,0,sizeof(Matrix));
        memset(f,0,sizeof(f));
        for(int i=0;i<r;i++)
            for(int j=0;j<=i;j++)
                scanf("%d",&Matrix[i][j]);
        for(int i=0;i<r;i++)
            for(int j=0;j<=i;j++){
                if(i==0&&j==0)
                    f[i][j]=Matrix[i][j];
                else if(j==0)
                    f[i][j]=f[i-1][j]+Matrix[i][j];
                else
                    f[i][j]=max(f[i-1][j],f[i-1][j-1])+Matrix[i][j];
            }
        int ans=-1;
        for(int i=0;i<r;i++)
            if(f[r-1][i]>ans)
                ans=f[r-1][i];
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值