POJ 1094Sorting It All Out(拓扑排序)

Sorting It All Out

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33756 Accepted: 11806

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:输入n和m,n是有n个点,m是有m条边,然后输入m行,如果这n个顶点可以构成有向无环路(拓扑),则输出第一种形式,如果有环就输出第二种形式,否则输出第三种形式。

题解:判断是否是拓扑排序,而且要每输入一行就要去进行判断。


#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

int n, m;
int flag;
int Map[50][50];//用来储存链接矩阵
int in[50];//记录入度
int rein[50];//临时记录入度
char a[50];//记录排序
int k;

void topu()
{
    int i, j, pos;
    for(i = 1; i <= n; i++)//临时入度
    {
        rein[i] = in[i];
    }

    for(i = 1; i <= n; i++)
    {
        int s = 0;
        for(j = 1; j <= n; j++)//寻找入度为0的顶点并记录加和
        {
            if(rein[j] == 0)
            {
                s++;
                pos = j;
            }
        }

        if(s == 0)//说明没有找到入度为0的顶点,表示有环
        {
            flag = 1;
            return ;
        }
        else if(s > 1)//第三种情况,例如多起点或无法比较两点的大小
        {
            flag = -1;
        }

        a[k++] = pos + 'A' - 1;//储存
        a[k] = '\0';

        rein[pos] = -1;

        for(j = 1; j <= n; j++)//将与pos这个位置相连的所有的点的入度减一
        {
            if(Map[pos][j])
            {
                rein[j]--;
            }
        }

    }
}

int main()
{
    char str[4], i;
    while(cin>>n>>m && n && m)
    {
        memset(Map, 0, sizeof(Map));
        memset(in, 0, sizeof(in));
        memset(a, 0, sizeof(a));

        int sign = 0;

        for(i = 1; i <= m; i++)
        {
            k = 0;
            flag = 0;

            cin>>str;
            Map[str[0] - 'A' + 1][str[2] - 'A' + 1] = 1;
            in[str[2] - 'A' + 1] ++;
            if(sign == 1)//已经满足了其中一种情况,不在进行操作
                continue;
            topu();

            if(flag == 1)
            {
                printf("Inconsistency found after %d relations.\n",i);
                sign=1;
            }
            if(flag == 0)
            {
                printf("Sorted sequence determined after %d relations: %s.\n",i,a);
                sign=1;
            }
        }
        if(flag == -1)
        {
            printf("Sorted sequence cannot be determined.\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值