POJ 3552Round Numbers(组合数学)

Round Numbers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12657 Accepted: 4861

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation ofN has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

Source

题意:

输入两个十进制正整数ab,求闭区间 [a ,b]内有多少个Round number

所谓的Round Number就是把一个十进制数转换为一个无符号二进制数,若该二进制数中0的个数大于等于1的个数,则它就是一个Round Number

题解:

和上一篇博客的思想是一样的,只不过是求两个数值的差;

#include <iostream>
#include <stdio.h>

using namespace std;

int c[33][33] = {0};
int too[35];

void init()
{
    int i, j;
    for(i = 0; i < 33; i++)
    {
        for(j = 0; j <= i; j++)
        {
            if(!j || i == j)
                c[i][j] = 1;
            else
                c[i][j] = c[i-1][j-1] + c[i-1][j];
        }
    }
    //c[0][0] = 1;
}


int RN(int n)
{
    int i, j;
    int sum = 0;

    too[0] = 0;
    int len = 0;
    while(n)
    {
        too[++len] = n%2;
        n /= 2;
    }
    for(i = 1; i < len-1; i++)
        for(j = i/2+1; j <= i; j++)
        {
            sum += c[i][j];
        }

    int zero = 0;  //从高位向低位搜索过程中出现0的位的个数
    for(i = len-1; i >= 1; i--)
        if(too[i])
        {
            for(j = (len+1)/2-(zero+1); j <= i-1; j++)
                sum += c[i-1][j];
        }
        else
            zero++;
    return sum;
}

int main()
{
    int a, b;
    init();
    scanf("%d %d", &a, &b);
    printf("%d\n", RN(b+1) - RN(a));
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值