PAT A1020. Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2


#include <cstdio>
#include <stdlib.h>
#include <algorithm>
#include <vector>
#include <cstring>
#include <math.h>
#include <string>
#include <iostream>
#include <queue>
using namespace std;
#define Max 32
struct Tnode{
	int data;
	Tnode *rchild;
	Tnode *lchild;
};
int pre[Max],in[Max],post[Max];
int n,m=0,k;
Tnode* create (int InL,int InR,int PostL,int PostR)
{
	if(PostL>PostR) return NULL;
	Tnode * q = new Tnode ;
	q->data = post[PostR];
	int flag , i;
	for(i=InL;i<=InR;i++)
	{
		if(in[i]==post[PostR])
		{
			break;
		}
	}
	flag = i-InL;
	q->lchild=create(InL,flag-1,PostL,PostL+flag-1);
	q->rchild=create(flag+1,InR,PostL+flag,PostR-1);
	return q;
}
  

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&post[i]);
	}
	for(int i=0;i<n;i++)
	{
		scanf("%d",&in[i]);
	}
	k=n;
	Tnode* root = new Tnode;
	Tnode* q=new Tnode;
	root = create(0,n-1,0,n-1);
	queue<Tnode*> Q;
	Q.push(root);
	while(n--)
	{
		q = Q.front();
		Q.pop();
		printf("%d",q->data);
		m++;
		if(q->lchild!=NULL) Q.push(q->lchild);
		if(q->rchild!=NULL) Q.push(q->rchild);
		if(m < k)  printf(" ");
	}
	system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值