NYOJ--Dinner

Dinner

时间限制: 100 ms  |  内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示

The tableware only contains: bowl, knife, fork and chopsticks.

解析:最后每行输出最后一个单词不控制空格的话也可ac,nyoj上这点没严格控制

用容器vector写的,可以直接用数组,时间基本一样哈!

#include <iostream>
#include <vector>
#include <string>
using std::endl;
using std::cin;
using std::cout;
using std::string;
using std::vector;
int main()
{
	int n;
	vector<string> vs;
	while(cin >> n)
	{
		for(int i=0;i<n;++i)
		{
			string str;
			cin >> str;
			vs.push_back(str);
		}
		for(int i=0;i<n;++i)
		{
			string temp;
			temp = vs[i];
			if(temp.compare("bowl") ==0 || temp.compare("knife") ==0 || temp.compare("fork") ==0 ||temp.compare("chopsticks") == 0)
			{
				cout << temp;
				//判断是否输出空格
				if(i!=n-1)
				   cout << " ";
			}
		}
		cout << endl;
		vs.clear();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值