UVa--Rotating Sentences

Rotating Sentences 

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"
解析:最近看刘汝佳的算法入门,上面的配套习题是UVa Online Judge上面的习题,所以就尝试的做了做,自我感觉上面的题不适合入门,首先感觉读题上面有点困难,可能是因为自己英语太水了,其次感觉题目说的不清不楚的,比如这道有两个易错点,
首先,当某行的字数长度不够时要输出空格,但是题目中并未找到说明哈
然后,就是提示的格式错误,最后一行一定要输出回车,不知道因为这wa了多少
除了这,剩下的就是水题了哈!
#include <iostream>
#include <string>
using std::endl;
using std::cin;
using std::cout;
using std::string;
int main()
{
#ifdef LOCAL
	freopen("input.txt" , "r" , stdin);
	freopen("output.txt" , "w" , stdout);
#endif
	string str[105];
	int i=0 , maxlength = 0;
	while(getline(cin , str[i]))
	{
		int length = str[i].length();
		if(length > maxlength)
			maxlength = length;
		if(length == 0)
			break;
		i++;
	}
	for(int k=0;k<maxlength;++k)
	{
		for(int j=i-1;j>=0;--j)
		{
			if(k<str[j].length())
				cout << str[j][k];
			else
				//如果某行长度不够补齐空格
				cout << ' ';
		}
		//最后一行输出换行符
		cout << endl;
	}
	return 0; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值