HDU1051--Wooden Sticks

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11070    Accepted Submission(s): 4553


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 
解析:简单的贪心问题,但是有点非常容易错误,每个stick只能减免一个的stick的执行时间,所以每次的数据需要更新,方法直接排序,可以按照长度或者重量排序都可以,对每个stick进行标记看是否执行过,然后从头开始遍历,对于每个stick看能减肥几个,没减免一个就需要更新其比较的长度或者重量,如果还是不清楚的话,可以看我的代码哈!
贴一下自己的代码哈!
#include<iostream>
#include <algorithm>
using std::endl;
using std::cin;
using std::cout;
using std::sort;
const int MAXN = 5000 + 200;
struct stick{
	int length;
	int weight;
	//标记是否访问过
	int tag;
}sticks[MAXN];
//排序函数
bool cmp(stick a , stick b)
{
	if(a.length > b.length)
		return true;
	if(a.length == b.length)
		return a.weight > b.weight;
	return false;
}
int main()
{
#ifdef LOCAL
	freopen("input.txt" , "r" , stdin);
#endif
	int T;
	cin >> T;
	while(T--)
	{
		int n;
		cin >> n;
		for(int i=0; i<n; ++i)
		{
			cin >> sticks[i].length >> sticks[i].weight;
			sticks[i].tag = 0;
		}
		sort(sticks , sticks+n , cmp);
		int time = 0 , weight;
		for(int i=0; i<n; ++i)
		{
			//对每个未访问过的stick进行遍历
			if(!sticks[i].tag)
			{
				sticks[i].tag = 1;
				time++;
				weight = sticks[i].weight;
				for(int j=i+1; j<n; ++j)
				{
					if(!sticks[j].tag && weight >= sticks[j].weight)
					{
						//如果符合条件可以减免然后更新下次比较的重量
						weight = sticks[j].weight;
						//更新访问标记
						sticks[j].tag = 1;
					}
				}
			}
		}
		cout << time << endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值