HDU 5311 Hidden String

63 篇文章 0 订阅
Problem Description

Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string ss of length nn. He wants to find three nonoverlapping substrings s[l_1..r_1]s[l1..r1]s[l_2..r_2]s[l2..r2]s[l_3..r_3]s[l3..r3] that:

  1. 1 \le l_1 \le r_1 < l_2 \le r_2 < l_3 \le r_3 \le n1l1r1<l2r2<l3r3n

  2. The concatenation of s[l_1..r_1]s[l1..r1]s[l_2..r_2]s[l2..r2]s[l_3..r_3]s[l3..r3] is "anniversary".

Input

There are multiple test cases. The first line of input contains an integer TT (1 \le T \le 100)(1T100), indicating the number of test cases. For each test case:

There's a line containing a string ss (1 \le |s| \le 100)(1s100) consisting of lowercase English letters.

Output

For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).

Sample Input
2
annivddfdersewwefary
nniversarya
Sample Output
YES

NO

暴力dfs即可

#include<cstdio>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#include<string>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const ll maxn = 205;
int T, n, m, p, q, flag, f[maxn];
char s[maxn], c[maxn] = "anniversary";

void dfs(int x, int y, int z)
{
    if (z <= 3 && !c[x]) { flag = 1; return; }
    if (z > 3 || !c[x] || !s[y]) return;    
    dfs(x, y + 1, z); 
    if (c[x]==s[y])
    {
        while (c[x] && s[y] && c[x] == s[y]) x++, y++;
        dfs(x, y, z + 1);
    }
}

int main()
{
    cin >> T;
    while (T--)
    {
        scanf("%s", s);
        flag = 0;
        dfs(0, 0, 0);
        if (flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值