BetterWorld的专栏

Have a better world.

CentOS 7安装gVim

vi(visual interface)是linux下备受欢迎的编辑器。相应的有了vim(vi improved)。CentOS 7默认安装了vi与vim。而gVim相对于vim而言gui系统界面更丰富,而且支持鼠标操作,支持ctag与类结构图类似的视图。 CentOS 7安装gVim非常简单y...

2016-04-22 19:55:49

阅读数 4085

评论数 0

CentOS 7安装Chrome浏览器

PROBLEN从google官方网站上下载rpm安装包。然后安装已经下载好的Chrome rpm安装包报错。rpm -ivh google-chrome-stable_current_x86_64.rpm error: Failed dependencies: lsb >= 4.0...

2016-04-19 23:16:21

阅读数 2575

评论数 0

CentOS 7 安装matplotlib

PROBLEMCentOS 7下 安装matplotlib。pip install matplotlib报错如下:[root@localhost Desktop]# pip install matplotlib Collecting matplotlib Using cached matplo...

2016-04-16 22:31:16

阅读数 5565

评论数 0

Centos7多版本python包不能通用问题

PROBLEM多版本python共存时安装第三方包不能共用。REASONlinux系统自带python,不过版本比较低,多为2.7版本。而且许多已经安装好的包都是依赖与这个版本。有时需要高版本的python,就存在多个版本python共存的情形。如果使用ubuntu,apt-get安装版本冲突情况...

2016-04-16 21:57:25

阅读数 1617

评论数 0

centos7修改文件写权限

centos7下不同的文件对应不同的用户权限。有些文件需要root权限才能编辑。但是如果用了IDE,比如Pycharm打开文件,默认就是当前用户,不能象su vim 之类的使用root权限写文件。此时就需要修改文件的权限。chmod a+w -R /home/PycharmProjects/如此,...

2016-04-15 19:37:42

阅读数 42865

评论数 0

CentOS 7 更新源 – 使用国内 163 yum 源

使用163源,具体步骤:直接打开 163 源网站:http://mirrors.163.com/.help/centos.html按照使用说明,还是先备份一下源(使用下面的命令重命名原来的源,如果有错误,再改回来):mv /etc/yum.repos.d/CentOS-Base.repo /etc...

2016-04-13 21:25:19

阅读数 11929

评论数 0

required opengl extension,please update your opengl driver

BUG:使用steam启动游戏时,报出一个opengl驱动不支持的错误。required opengl extension,please update your opengl driverREASON:opengl相关驱动不是最新的。SOLUTION:将驱动更新到最新状态。sudo add-apt...

2016-04-10 00:37:33

阅读数 1467

评论数 0

ubuntu14.04LTS安装steam

自从告别虚拟机使用ubuntu之后,开始关注linux下可用的游戏平台steam。据说可以玩国外的大型竞技游戏dota2,于是便想尝试下。 首先从steam官网下载最新的安装包steam_latest.deb,双击在software-center中进行安装。BUG:安装后点击图标没有反应。命令行...

2016-04-09 21:57:35

阅读数 5152

评论数 0

ubuntu无法打开software-center

BUG:在ubuntu14.04LTS版本下,点击软件中心图标,过了一会软件未能启动,没有动静。用命令行启动报如下错误:perrin@LittleBlack:~/Desktop$ sudo software-center File "/usr/bin/software-center&...

2016-04-09 21:02:33

阅读数 7029

评论数 0

Sub-process /usr/bin/dpkg returned an error code (1) 问题解决

Sub-process /usr/bin/dpkg returned an error code (1) 问题解决ubuntu apt-get install软件时 有时候会碰到这个错误 Sub-process /usr/bin/dpkg returned an error code (1) ...

2016-04-07 22:45:47

阅读数 3545

评论数 0

win10 与ubuntu14.04.4 LTS双系统时间不统一解决

作为一个初、中级coder想提升段位,彻底告别codemonkey,于是买了SSD,然后毫不犹豫的win10、ubuntu双系统了,从此告别只能从虚拟机vmware体验linux的岁月。 装好之后,虽是双系统,一次只能提示一个系统项。需要切换时需要修改BIOS中第一引导磁盘选项。当然也可以用一些...

2016-04-06 23:20:16

阅读数 4339

评论数 2

提示
确定要删除当前文章?
取消 删除