Operation the Sequence(HDU 5063)

Operation the Sequence

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 440 Accepted Submission(s): 181


Problem Description
You have an array consisting of n integers: a1=1,a2=2,a3=3,,an=n . Then give you m operators, you should process all the operators in order. Each operator is one of four types:
Type1: O 1 call fun1();
Type2: O 2 call fun2();
Type3: O 3 call fun3();
Type4: Q i query current value of a[i], this operator will have at most 50.
Global Variables: a[1…n],b[1…n];
fun1() {
index=1;
for(i=1; i<=n; i +=2)
b[index++]=a[i];
for(i=2; i<=n; i +=2)
b[index++]=a[i];
for(i=1; i<=n; ++i)
a[i]=b[i];
}
fun2() {
L = 1;R = n;
while(L<R) {
Swap(a[L], a[R]);
++L;--R;
}
}
fun3() {
for(i=1; i<=n; ++i)
a[i]=a[i]*a[i];
}

Input
The first line in the input file is an integer T(1T20) , indicating the number of test cases.
The first line of each test case contains two integer n(0<n100000) , m(0<m100000) .
Then m lines follow, each line represent an operator above.

Output
For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).

Sample Input
  
  
1 3 5 O 1 O 2 Q 1 O 3 Q 1

Sample Output
  
  
2 4

Source


题意:

给你一些操作和一些询问,每次询问都要你给出相应结果。


分析:

如果按照一个一个操作后询问时在给出答案肯定会超时,所以可以换种思维:每次询问时我再往回操作找到解(我称作懒人思维==)。由于询问次数只有50,故时间复杂度为O(50*m);故应该不会超时。


#include<stdio.h>
#define N 100010
#define mod 1000000007
int n, notes[N], a[N];
//找出最初的位置
int solve(int oper, int position)
{
    for(int i=oper-1; i>=1; i--)
    {
        if(notes[i] == 1)
        {
            if(position <= (n+1)/2) position = 2*position-1;
            else position = 2*position-n-n%2;
        }
        else position = n-position+1;
    }
    return position;
}

int main()
{
    int T, m, position; //询问的位置
    char s[1];

    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n,&m);
        int oper = 1, times = 0;
        while(m--)
        {
            scanf("%s%d", s,&position);
            if(s[0] == 'O') //记录操作
            {
                if(position == 3) times++;
                else notes[oper++] = position; 
            }
            else
            {
                __int64 ans = solve(oper, position);
                for(int i=1; i<=times; i++)
                    ans = ans*ans%mod;
                printf("%I64d\n", ans);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值