uva 699 - The Falling Leaves

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=640

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?

We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value-1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single-1 (which would otherwise represent an empty tree).

Output

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

Sample Input

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1

Sample Output

Case 1:
7 11 3

Case 2:
9 7 21 15


思路:这显然是一道关于二叉树的题目,但是是否每个这样的题目我们都要建树呢

这道题建树显然很麻烦,而且查找同一竖直位置上的节点,很不好找

思路是使用一个数组来存储每个水平位置的和,arr[index]的值,代表水平位置为index的节点的和

根节点在数组中的位置,显然是数组长度除以2,设置为p

那么他的子节点,就是p-1,和p+1

依次类推

package test;

import java.util.Scanner;




public class Test{	
	static Scanner sc = new Scanner(System.in);
	static String line;
	static int n = 100;//水平位置最大数目
	static int[] sum = new int[n];//用来存储各个水平位置的和
	
	/**
	 * 输入并统计一棵子树,树根水平位置为p
	 * @param p
	 */
	public static void build(int p){
		int v;
		v = sc.nextInt();
		if(v==-1) return;
		sum[p] += v;
		build(p-1);
		build(p+1);
	}
	
	/**
	 * 初始化
	 * 根节点的水平位置在数组的中心
	 * @return
	 */
	public static boolean init(){
		int v;
		v = sc.nextInt();
		if(v==-1) return false;
		int pos = n/2;
		sum[pos] = v;
		build(pos-1);
		build(pos+1);
		return true;
	}
	
	public static void main(String[] args) {
		if(init()){
			int p = 0;
			while(sum[p]==0) p++;
			while(sum[p]!=0){
				System.out.println(sum[p]);
				p++;
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值