HDU 1518--Square(DFS)

 Square
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12479 Accepted Submission(s): 3971

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?


Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.


Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".


Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5



Sample Output

yes
no

yes

剪枝条件为判断符合条件的边数是否为4个,其次当一个边满足条件,需要从头重新搜索。。

以下AC代码:

#include<stdio.h>
#include<string.h>
int n,m;
int a[25],flag[25];
int mid;
int temp;
void dfs(int sum,int index,int count)
{
    if (count==4)
    {
        temp=1;
        return;
    }
    if(sum==mid)
    {
        dfs(0,0,count+1);
        if(temp)
        return;
    }
    int i;
    for(i=index;i<m;i++)
    {
        if(!flag[i] && sum+a[i]<=mid)
        {
            flag[i]=1;
            dfs(sum+a[i],i+1,count);
            if(temp)
                return;
            flag[i]=0;
        }
    }
}
int main()
{
    int i;
    int sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&m);
        for(i=0;i<m;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        if(sum%4)
        {
            printf("no\n");
            continue;
        }
        else
        {
            memset(flag,0,sizeof(flag));
            temp=0;
            mid=sum/4;
            dfs(0,0,0);

        }
            if(temp)
               printf("yes\n");
            else
               printf("no\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值