Uva 11300 Spreading the Wealth(数学,中位数)

96 篇文章 0 订阅
56 篇文章 0 订阅

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

    解题报告:《训练指南》上的一道好题。
    简单来说,就是有一组数,x[0]加1,x[1]则减1,x[2]则加1,依次类推。求min( abs(x[0] + abs(x[1]) + ... + abs{x[n-1])。
    做法呢,书上说的很明白了。关键时转化的过程实在是很巧妙,要好好感受一下。
    另外,可以用nth_element函数求中位数,比sort快。
    代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <vector>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define fff(i, n, m) for(int i=(n);i<=(m);i++)
#define ff(i, n) for(int i=0;i<(n);i++)
#define fout freopen
void work();
int main()
{
    #ifdef ACM
    fout("in.txt", "r", stdin);
    #endif

    work();
}

/

LL w[1111111];
LL c[1111111];

void work()
{
    int n;
    while(~scanf("%d", &n))
    {
        ULL tot = 0;
        ff(i, n) scanf("%lld", w+i), tot+=w[i];

        LL avr = tot/n;
        c[0]=0;
        ff(i, n) c[i] = c[i-1] + w[i] - avr;

        nth_element(c, c+n/2, c+n);

        LL x = c[n/2];
        ULL ans = 0;
        ff(i, n) ans+=abs(x-c[i]);

        printf("%llu\n", ans);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值