【POJ3321】Apple Tree【树状数组】

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44586 Accepted: 13153


Description
There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?


Input
The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output
For every inquiry, output the correspond answer per line.


Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output
3
2


中文翻译
一棵树上长了苹果,每一个树枝节点上有长苹果和不长苹果两种状态,两种操作,一种操作能够改变树枝上苹果的状态,另一种操作询问某一树枝节点一下的所有的苹果有多少。


解题思路
这道题可以用树状数组很快解决,先做一遍DFS序,把每个子树映射到一个区间,将问题转化为了区间操作,所以树状数组可以轻松实现这些操作。

图示DFS序:
在这里插入图片描述


代码

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int n,m,x,y,k,cnt,in[100010],out[100010],tree[100010],h[100010],v[100010];
char c;
struct c{
	int x,next;
}a[100010];
void add(int x,int y){
	++k;
	a[k].x=y;
	a[k].next=h[x];
	h[x]=k;
}
void dfs(int x){
	in[x]=++cnt;
	for(int i=h[x];i;i=a[i].next)
		dfs(a[i].x);
	out[x]=cnt;
}
void find(int x,int y){
	for(int i=x;i<=n;i+=i&(-i))
		tree[i]+=y;
}
int ans(int x){
	int bsy=0;
	for(int i=x;i;i-=i&(-i))
		bsy+=tree[i];
	return bsy;
}
int main(){
	scanf("%d",&n);
	for(int i=1;i<n;i++)
	{
		scanf("%d%d",&x,&y);
		add(x,y);
	} 
	dfs(1);
	for(int i=1;i<=n;i++)
	{
		find(in[i],1);
		v[i]=1;
	}
	scanf("%d",&m);
	for(int i=1;i<=m;i++)
	{
		cin>>c;
		scanf("%d",&x);
		if(c=='C')
		{
			if(v[x]) find(in[x],-1);	
			else find(in[x],1);
			v[x]=1-v[x];
		}
		if(c=='Q')
		printf("%d\n",ans(out[x])-ans(in[x]-1));
	}
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值