opencv 编译静态库

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/keyanxiaocaicai/article/details/79254562

1. 给他们了一个带跟踪版本

   出现问题:

    我编译的linux 版本出现的问题

     A. 因为甲方的opencv 版本是320 我的opencv版本是249 

        我要编译一个静态链接opencv 的libFaceTracer.so 给甲方

         所以我不能使用libopencv_imgproc.so libopencv_highgui.so

         我要链接libopencv_core.a 和 libopencv_highgui.a

         我去/home/gjge/local/lib 下面去找了 发现没有libopencv_highgui.a 这种文件

         所以去百度opencv 怎么生成静态库

         在cmake 的后面加上 -D BUILD_SHARED_LIBS=OFF  可以发现在/home/gjge/local/lib 后面生成了。a

          (opencv 的安装在package 目录下 to 自己)

         编译完甲方使用的时候还是说依赖其他的库、他告诉我说让我在编译的时候加上 -D WITH_OPENXR=OFF

         这样甲方那边可以编译过去

    B. 甲方运行的时候出现错误 

         [FATAL][2018-02-03 11:52:08.468290][layer_factory.hpp:69] Expression '(registry.count(type)) == (0)' failed.              Layer type Convolution already registered

        解决方法:检测和识别的库在makefile 里面是反的

    C. 甲方拿走之后出现识别不正确的问题

         他们反馈说是读取图片权限的问题。

     D. 甲方反馈问题:

         

        

          暂时没有解决。。。。等待解决

        

展开阅读全文

没有更多推荐了,返回首页