裸floyd大法

这个题主要就是裸的floyd大法 注意就是不要计算了重边 所以必须用vis标记...orz  


C - D
Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

Everyone knows how to calculate the shortest path in a directed graph. In fact, the opposite problem is also easy. Given the length of shortest path between each pair of vertexes, can you find the original graph?
 

Input

The first line is the test case number T (T ≤ 100). 
First line of each case is an integer N (1 ≤ N ≤ 100), the number of vertexes. 
Following N lines each contains N integers. All these integers are less than 1000000. 
The jth integer of ith line is the shortest path from vertex i to j. 
The ith element of ith line is always 0. Other elements are all positive. 
 

Output

For each case, you should output “Case k: ” first, where k indicates the case number and counts from one. Then one integer, the minimum possible edge number in original graph. Output “impossible” if such graph doesn't exist. 

 

Sample Input

       
       
3 3 0 1 1 1 0 1 1 1 0 3 0 1 3 4 0 2 7 3 0 3 0 1 4 1 0 2 4 2 0
 

Sample Output

       
       
Case 1: 6 Case 2: 4 Case 3: impossible
 

#include<cstdio>
int line[101][101];
int ver;
int floyd()
{
    int cnt=0;
    bool vis[101][101]={0};
    for(int k=1;k<=ver;k++){
        for(int i=0;i<=ver;i++){
            for(int j=0;j<=ver;j++){
                if(i==j||j==k||k==i)continue;
                if(!vis[i][j]&&line[i][j]==line[i][k]+line[k][j]){
                    vis[i][j]=1;
                    cnt++;
                }
                if(line[i][j]>line[i][k]+line[k][j])return -1;
            }
        }
    }
    return cnt;
}
int main()
{
    int cas,i,j,k,ans;
    scanf("%d",&cas);
    for(i=0;i<cas;i++){
        scanf("%d",&ver);
        for(j=1;j<=ver;j++){
            for(k=1;k<=ver;k++)scanf(" %d",&line[j][k]);
        }
        ans=floyd();
        if(ans==-1)printf("Case %d: impossible\n",i+1);
        else {
            printf("Case %d: %d\n",i+1,ver*(ver-1)-ans);
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值