Scrapy安装错误:Microsoft Visual C++ 14.0 is required

安装scrapy时出现错误

 error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools

,刚开始按照网上面的教程,也就是下载相应的twisted

解决方案

http://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted 下载twisted对应版本的whl文件(如我的Twisted‑17.5.0‑cp36‑cp36m‑win_amd64.whl),cp后面是python版本,amd64代表64位,运行命令:

pip install C:\Users\CR\Downloads\Twisted-17.5.0-cp36-cp36m-win_amd64.whl
  • 1

其中install后面为下载的whl文件的完整路径名
安装完成后,再次运行:

pip install Scrapy
发现还是报错,错误原因是因为我自己创建了一个虚拟环境,需要在虚拟环境下加载这个whl才不会报错,在全局下加载whl之后,还是会报错的,最后下载成功,终于不报错了大哭
阅读更多

没有更多推荐了,返回首页