数据结构实验之求二叉树后序遍历和层次遍历

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu

示例输出

dgebfca
abcdefg
linux
xnuli
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data;
    struct node *l,*r;
};
struct node*creat(char a[],char b[],int m)
{
    char *p;
    struct node*t;
    if(m==0)
        return NULL;
    t=(struct node*)malloc(sizeof(struct node));
    t->data=a[0];
    for(p=b;p;p++)
    {
        if(*p==a[0])
            break;
    }
    int k=p-b;
    t->l=creat(a+1,b,k);
    t->r=creat(a+k+1,p+1,m-1-k);
    return t;
}
void rearpop(struct node *t)
{
    if(t!=NULL)
    {
        rearpop(t->l);
        rearpop(t->r);
        printf("%c",t->data);
    }
}
void seque(struct node *tree)
{
    struct node *q[100];
    int head = 0;
    int tail = 1;
    q[head] = tree;
    while(head < tail){
        if(q[head] != NULL){
            printf("%c", q[head]->data);
            q[tail++] = q[head]->l;
            q[tail++] = q[head]->r;
        }
        head++;
    }
}
int main()
{
    struct node*t;
    int n,m;
    char a[60],b[60];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",a);
        scanf("%s",b);
        m=strlen(a);
        t=creat(a,b,m);
        rearpop(t);
        printf("\n");
        seque(t);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值