POJ 3087 Shuffle'm Up(模拟+读题)

POJ 3087

http://poj.org/problem?id=3087

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

题意:有两堆数量为C的筹码,要求按照“规定的方法”放置成一堆数量为2*C的筹码,要得到指定的排列顺序,否则从中间分成两堆,重复按照“规定的方法”放置成一堆……求操作需要进行的次数。如果不能得到指定的排列顺序则输出-1。

分析:这是kuangbin带你飞简单搜索里的题,但用的是模拟的方法。这道题最大的问题可能是读懂题意了……一开始我也没读懂题,毕竟英语和语文能力低下。

用第一个样例来说,首先的序列是:

S1 = AHAH
S2 = HAHA

“规定的方法”为:取S2第一个筹码H放在最下面,S1的第一个筹码A放在筹码H上,再将S2第二个筹码A放在前两个筹码上,再将S1第二个筹码H放在前三个筹码上……以此类推。

得到第一次放置的序列:

S12 = HAAHHAAH

然后判断出S12不是指定排列顺序,所从中间分开成新的两堆筹码,S1前C个,S2后C个,得到:

S1 = HAAH

S2 = HAAH

再次按照“规定的方法”放置成一堆:

S12 = HHAAAAHH

S12与指定排列顺序相等。所以得到操作需要进行2次。

理解题意之后就非常好模拟了,只要让操作不断进行,记录操作次数即可。

注意保存第一次操作的结果,如果第n次(n>1)的操作结果与第一次相同,代表出现循环无法得到指定序列。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

int N,C;
char a[105],b[105],c[210],need[210],first[210];

int main(){
    cin >> N;
    int count=0;
    while(N--){
        cin >>C;
        count++;
        cin >> a >> b >> need;
        int cnt=0;
        for(int i=0;i<C;i++){
            c[cnt++]=b[i];
            c[cnt++]=a[i];
        }
        c[cnt]='\0';
        strcpy(first,c);
        if(strcmp(c,need)==0){
            cout << count << " " << 1 << endl;
            continue;
        }
        int ok=1;
        int time=1;
        while(strcmp(c,need)){
            time++;
            for(int i=0;i<C;i++){
                a[i]=c[i];
                b[i]=c[i+C];
            }
            a[C]='\0';
            b[C]='\0';
            cnt=0;
            for(int i=0;i<C;i++){
                c[cnt++]=b[i];
                c[cnt++]=a[i];
            }
            c[cnt]=='\0';
            if(strcmp(c,first)==0){
                ok=0;
                break;
            }

        }
        //cout << "c = " << c<< endl;
        if(ok)cout << count << " " << time << endl;
        else cout << count << " " << -1 << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值