4-2 电子时钟中的运算符重载

4-2 电子时钟中的运算符重载

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
通过本题目的练习可以运算符重载的方法;
设计一个时间类Time,私有数据成员有hour(时)、minute(分)、second(秒);
公有成员函数有:setHour(int)设置数据成员hour的值,非法的输入默认为12;setMinue(int)设置数据成员minute的值,非法输入默认为0;setSecond(int)设置数据成员second的值,非法输入默认为0;setTime(int,int,int)设置时、分、秒三个数据成员的值;三个成员函数int getHour(); int getMinute(); int getSecond();分别用于获取时间对象的属性值。
定义两个构造函数Time(); 和 Time(int,int,int);
定义一个成员函数void displayTime(); 用于显示时间,注意格式为 hh:mm:ss,位数不够用0填充;
定义一个时钟增加1的成员函数 void tick(); 把second的值加1,并注意是否到60;
定义一个成员或友元函数 bool operator= =(….); 判断两个时间对象的值是否相等;
定义一个成员或友元函数bool operator>(…..); 判断第一个时间对象的值是否大于第二个时间对象的值。
 
 
在主函数main()中指定开始时间和结束时间,并调用相应成员函数,显示从开始时间到结束时间之间所有时间对象的值,其格式见示例输出。
Input

输入6个整数,之间用一个空格间隔;分别表示开始时间的时、分、秒和结束时间的时、分、秒的值

Output

从开始时间到结束时间之间所有时间对象的值;每个值占一行,格式为hh:mm:ss

Example Input
01 01 01 01 01 10
Example Output
01:01:01
01:01:02
01:01:03
01:01:04
01:01:05
01:01:06
01:01:07
01:01:08
01:01:09
01:01:10
Hint
输入
11 10 12 10 12 56
输出
The begin time is not earlier than the end time!

Author

#include<iostream>
#include<iomanip>
//#include<bits/stdc++.h>
using namespace std;
class Time         // 类的名称注意 大写, 大写, 大写
{
    private: int hour, minute, second;
    public:
    Time()
    {
        hour = 12;
        minute = 0;
        second = 0;
    }
    Time(int a, int b, int c)
    {
        if(a>12 || a<0) a = 12;
        hour = a;
        if(b>=60 || b<0) b = 0;
        minute = b;
        if(c>=60 || c<0) c = 0;
        second = c;
    }
    void display()
    {
        cout<<setfill('0')<<setw(2)<<hour<<":"<<setfill('0')
        <<setw(2)<<minute<<":"<<setfill('0')<<setw(2)<<second<<endl;
    }
    void tick()
    {
        second++;
        if(second>=60)
        {
            second -= 60;
            minute++;
            if(minute>=60)
            {
                minute-=60;
                hour++;
                if(hour>=12)
                {
                    hour = 12;
                    minute = 0;
                    second = 0;
                }
            }
        }
    }
    bool operator==(Time &c2)
    {
        if(hour!=c2.hour)
            return false;
        if(minute!=c2.minute)
            return false;
        if(second!=c2.second)
            return false;
        return true;
    }
      int getsum()
    {
        return hour*3600+minute*60+second;
    }
    bool operator >(Time &c2)
    {
        if(getsum()>c2.getsum())
            return true;
        return false;
    }
};
int main()
{
    int a, b, c, d, e, f;
    cin>>a>>b>>c>>d>>e>>f;
    Time x(a, b, c), y(d, e, f);
    if(x>y)
        cout<<"The begin time is not earlier than the end time!"<<endl;
    else
    {
        while(!(x>y))
    {
        x.display();
        x.tick();
    }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值