openssl-devel和openssl 是什么具体关系

[转自] https://zhidao.baidu.com/question/919579491101051499.html


Redhat在封装openssl的时候,把openssl分成了几个部分,执行码部分就是 openssl-1.0.0-27.el6.x86_64 这种包。

openssl-devel-1.0.0-27.el6.x86_6 4 这个就是包含了头文件,头文件参考,某些库文件等跟开发相关的东西。

mod_ssl-2.2.15-26.el6.x86_64 这个不是open ssl 本身的东西,是apache的模块。

你在 http://www.openssl.org/source/ 上下载的源码编译安装后得到的东西就是openssl-1.0.0-27.el6.x86_64和openssl-devel-1.0.0-27.el6.x86_64这两个包加在一起的内容。

另外,OpenSSL是分系列的,每个系列下再分版本 a b c d e。。。。

目前常用的是 0.9.8 1.0.0 1.0.1 三个系列。

RHEL 6.4 是openssl 1.0.0 系列的版本。
RHEL 6.5 是 openssl 1.0.1 系列的版本。

Redhat 提供的openssl升级包的版本一般是 openssl-1.0.0-27.el6.X.x86_64.rpm 这种。 Redhat 会把OpenSSL发布的补丁整合到现有版本中去,叫做backport。

例如,RHEL 6.4 目前的最新的OpenSSL就是2014-06-05发布的 openssl-1.0.0-27.el6_4.4.x86_64.rpm 和 openssl-devel-1.0.0-27.el6_4.4.x86_64.rpm 
RHEL 6.5 则是2014-08-13发布的 openssl-1.0.1e-16.el6_5.15.x86_64.rpm 和 openssl-devel-1.0.1e-16.el6_5.15.x86_64.rpm。

因为不同系列的OpenSSL,存在的安全漏洞或者BUG不一定相同,所以版本要根据系列来判断。
当然,如果你愿意手动编译安装openssl,那么也可以,只是注意相关软件的依赖。
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页