1949: Fibonacci Numbers

 1949: Fibonacci Numbers


StatusIn/OutTIME LimitMEMORY LimitSubmit TimesSolved UsersJUDGE TYPE
stdin/stdout3s16384K775220Special Test
A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1)=1, f(2)=1, f(n>2)=f(n-1)+f(n-2)

Your task is to take a number as input, and print that fibonacci number.

Sample Input

100

Sample Output

354224848179261915075

Note:

No generated fibonacci number in excess of 1000 digits will be in the test data, i.e. f(20)=6765 has 4 digits.
#include <stdio.h>
#include <string.h>
#define maxn  2000

int main()
{
 int n;
 while(scanf("%d", &n) != -1)
 {
  int a[maxn + 1] = {0}, b[maxn + 1] = {0}, c[maxn + 1] = {0};
  b[maxn] = 1;
  while(n--)
  {
   c[maxn] = 0;
   for(int i = maxn; i > 0; --i)
   {
    c[i] += a[i] + b[i];
          c[i - 1] = c[i] / 10;
          c[i] %= 10;
   }
   memcpy(a, b, sizeof(b));
   memcpy(b, c, sizeof(c));
  }
  bool flag = false;
  for(int i = 0; i <= maxn; ++i)
  {
   if(flag || a[i] || i == maxn)
   {
    printf("%d", a[i]);
    flag = true;
   }
  }
  printf("/n");
 }
 return 0;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值