2248: Sequence

2248: Sequence


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K340105Standard
Jojer has been given a sequence of integers, and he should find the next integer of the sequence. Can you help him? Just see the samples to understand the problem.

Input

The input consists of several test cases. Each case will give you an integer N ( 0 < N < 21 ) which indicates the number of the integers on the first line. And N integers on the next line.

Output

You should output the next integer of the sequence.

Sample Input

2
10 12

3
7 8 11

4 
9 9 9 9

1
2

Sample Output

14
16
9
2

 

Problem Source: fennec

#include<stdio.h>
int main()
{
    int a[50][50];
    int n,i,j;
    while(scanf("%d",&n)==1)
    {
        for(i=0;i<n;i++) scanf("%d",&a[0][i]);
        for(i=1;i<n;i++) for(j=0;j+i<n;j++) a[i][j]=a[i-1][j+1]-a[i-1][j];
        a[n-1][1]=a[n-1][0];
        for(i=n-2;i>=0;i--)  a[i][n-i]=a[i][n-i-1]+a[i+1][n-i-1];
        printf("%d/n",a[0][n]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值