poj 3436 ACM Computer Factory

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,P Di,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part j, Di,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ N ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint

Bold texts appearing in the sample sections are informative and do not form part of the actual data.

 

 //

给几台机器,再给出每台机器能处理的电脑数量、输入时能接受电脑的情况和输出后电脑的情况。
问最多能生产多少电脑,课可生产电脑的生产线的流量又是如何。

因为每个点的接受能力有限,需要拆点.
拆点v时,把点v和它的对应点n+v连接一条流为q[v]的弧,然后用别的合法点连向v,
用n+v出去连别的合法的点,其实就是产生一条弧用于限制流量。

然后就是相关节点的连接了。*/

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf=(1<<28);
const int point_num=300;
int cap[point_num][point_num],dist[point_num],gap[point_num];//初始化见main里面
int s0,t0,n;//源,汇和点数
int f[point_num][point_num];
int find_path(int p,int limit=0x3f3f3f3f)
{
    if(p==t0)   return limit;
    for(int i=0;i<n;i++)
    if(dist[p]==dist[i]+1  &&  cap[p][i]>0)
    {
       int t=find_path(i,min(cap[p][i],limit));
       if(t<0)   return t;
       if(t>0)
       {
            cap[p][i]-=t;f[p][i]+=t;
            cap[i][p]+=t;f[i][p]-=t;
            return t;
       }
    }
    int label=n;
    for(int i=0;i<n;i++)  if(cap[p][i]>0)  label=min(label,dist[i]+1);
    if(--gap[dist[p]]==0  ||  dist[s0]>=n )   return -1;
    ++gap[dist[p]=label];
    return 0;
}
int sap()
{
    //初始化s,t
    s0=0,t0=n-1;
    int t=0,maxflow=0;
    memset(f,0,sizeof(f));
    gap[0]=n;
    while((t=find_path(s0))>=0) maxflow+=t;
    return maxflow;
}
int in[100][100],out[100][100];
int val[100];
int p;
int ans[100][3];
bool Link(int out[100], int in[100])
{
    for (int i = 1; i <= p; i++)
        if (out[i]+in[i]==1)
            return false;
    return true;
}
bool isNULL(int in[100]) /// 与源点相连
{
    for (int i = 1; i <= p; i++)
        if (in[i] == 1)
            return false;
    return true;
}
bool isFULL(int out[100]) /// 与汇点相连
{
    for (int i = 1; i <= p; i++)
        if (out[i] != 1)
            return false;
    return true;
}

int main()
{
    while(scanf("%d%d",&p,&n)==2)
    {
        //初始化
        memset(cap,0,sizeof(cap));
        memset(dist,0,sizeof(dist));
        memset(gap,0,sizeof(gap));
        //...
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
            for(int j=1;j<=p;j++) scanf("%d",&in[i][j]);
            for(int j=1;j<=p;j++) scanf("%d",&out[i][j]);
        }
        for(int i=1;i<=n;i++)
        {
            cap[i][i+n]=val[i];
            if(isNULL(in[i])) cap[0][i]=val[i];
            if(isFULL(out[i])) cap[i+n][n*2+1]=val[i];
            for(int j=1;j<=n;j++)
            {
                if(i!=j&&Link(out[i],in[j]))
                {
                    cap[i+n][j]=val[i];
                }
            }
        }int t=n;n=n*2+2;
        int maxflow=sap();
        int link=0;
        for(int i=1;i<=t+t;i++)
        {
            for(int j=1;j<=t+t;j++)
            {
                if(i!=j&&f[i][j]>0&&i!=t+j&&i+t!=j)
                {
                    ans[link][0]=(t+i-1)%t+1;
                    ans[link][1]=(t+j-1)%t+1;
                    ans[link++][2]=f[i][j];
                }
            }
        }
        printf("%d %d\n",maxflow, link);
        for (int i = 0; i < link; i++)
        printf("%d %d %d\n", ans[i][0], ans[i][1], ans[i][2]);
    }
    return 0;
}


 


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值