PAT (Advanced Level)1127. ZigZagging on a Tree (30)

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
//1127. ZigZagging on a Tree(30)

#include<iostream>
#include<vector>
#include<queue>
using namespace std;

vector<int> postorder(31);
vector<int> inorder(31);
vector<vector<int>> levels(31);

void buildTree(int pl, int pr, int il, int ir, int level)
{

	if (pl > pr || il > ir)
		return;
	int root = postorder[pr], i = 0;
	while (inorder[il + i] != root) i++;
	levels[level].push_back(root);
	buildTree(pl, pl + i - 1, il, il + i - 1, level + 1);
	buildTree(pl + i, pr - 1, il + i + 1, ir, level + 1);
}

void zigzag()
{
	cout << levels[0][0];
	bool zigzag = false;
	for (int i = 1; i < levels.size() && !levels[i].empty(); i++)
	{
		if (zigzag)
		{
			for (int j = levels[i].size() - 1; j >= 0; j--)
			{
				cout << " " << levels[i][j];
			}
		}
		else
		{
			for (int j = 0; j < levels[i].size(); j++)
			{
				cout << " " << levels[i][j];
			}
		}
		zigzag = !zigzag;
	}
}

int main()
{
	int N;
	while (cin >> N)
	{
		for (int i = 0; i < N; i++)
			cin >> inorder[i];
		for (int i = 0; i < N; i++)
			cin >> postorder[i];
		buildTree(0, N - 1, 0, N - 1, 0);
		zigzag();
	}
}

看着道题的提交正确率大于50%,很丧很丧,现在看到图和树的题不等看到题目心里就已经打起了退堂鼓。理论都会,一落实到代码上就无从下手。

马上PAT了,马上面试了,人生的路口真的好难走,怪不惜时光。

代码来源于大神,地址


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值