HUD Intersection 5120(两圆环相交求相交面积)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 2754    Accepted Submission(s): 1025


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 

Source
 

Recommend
liuyiding

题意:两圆环相交,求两圆环相交的面积

对着模板打了,错了好多遍,最后知道是圆环相交的面积

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define Pi 3.14159265358979
struct node
{
    double x,y,r;
}q[10];
double f(node a,node b)
{
    double d=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    if(a.r+b.r<=d)
    {
        return 0;
    }
    double r=a.r>b.r?b.r:a.r;
    if(fabs(a.r-b.r)>=d)return Pi*r*r;
    double k1=acos((a.r*a.r+d*d-b.r*b.r)/(2.0*a.r*d));
    double k2=acos((b.r*b.r+d*d-a.r*a.r)/(2.0*b.r*d));
    double s1=k1*a.r*a.r-a.r*sin(k1)*a.r*cos(k1);
    double s2=k2*b.r*b.r-b.r*sin(k2)*b.r*cos(k2);
    return s1+s2;
}
int main()
{
    double r1,r2,x1,x2,y1,y2;
    int t;
    scanf("%d",&t);
    for(int h=1;h<=t;h++)
    {
        scanf("%lf%lf",&r1,&r2);
        scanf("%lf%lf",&q[0].x,&q[0].y);
        scanf("%lf%lf",&q[1].x,&q[1].y);
        q[1].r=r2;
        q[0].r=r2;
        double s1=f(q[0],q[1]);//dada
        //printf("%.6lf\n",s1);
        q[0].r=r1;
        double s2=f(q[0],q[1]);//daxiao
        //printf("%.6lf\n",s2);
        q[1].r=r1;
        double s3=f(q[0],q[1]);//xiaoxiao
        printf("Case #%d: %.6lf\n",h,s1-2*s2+s3);

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值