渗透之—— Kali中一键更新Metasploit框架

转载请注明出处:https://blog.csdn.net/l1028386804/article/details/86593093

最近,我升级了Kali系统,升级后,尼玛Metasploit各种蛋疼的事情就发生了,我通过Metasploit整合OpenVAS,最后执行导入数据库的时候,尼玛就报出了如下错误:

opts must include a valid :workspace

于是我感觉在msfconsole下,执行banner命令查看版本,我去,竟然是:metasploit v5.0.1-dev-

咋就变成了开发版本了呢?蛋疼,怎么会升级为开发版本???!!!,Kali??!!无语中。。。

那么,如何解决这个问题,我想到了升级Metasploit,于是一顿操作猛如虎,解决了这个问题,下面就如何一键升级Metasploit跟大家分享下:

其实很简单,这里我将各种操作整理成了一个脚本:update_metasploit.sh,内容如下:

curl https://raw.githubusercontent.com/rapid7/metasploit-omnibus/master/config/templates/metasploit-framework-wrappers/msfupdate.erb > msfinstall && \
chmod 755 msfinstall && \
./msfinstall

将脚本上传到Kali赋予相应的权限,执行脚本,OK,问题解决!!!

冰 河 CSDN认证博客专家 hive storm hadoop
微信搜一搜【冰河技术】微信公众号,关注这个有深度的程序员,每天阅读超硬核技术干货,公众号内回复【PDF】有我准备的一线大厂面试资料和我原创的超硬核PDF技术文档,以及我为大家精心准备的多套简历模板(不断更新中),希望大家都能找到心仪的工作,学习是一条时而郁郁寡欢,时而开怀大笑的路,加油。如果你通过努力成功进入到了心仪的公司,一定不要懈怠放松,职场成长和新技术学习一样,不进则退。如果有幸我们江湖再见!
©️2020 CSDN 皮肤主题: Age of Ai 设计师:meimeiellie 返回首页
实付 9.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值