Packets

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 56518 Accepted: 19221

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

POJ1017 Packets(贪心算法训练)

Time Limit: 1000MS          Memory Limit: 10000K          Total Submissions: 51306          Accepted: 17391

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

题目大意

      公司共有底面面积为1*1、2*2、3*3、4*4、5*5、6*6,高度同为H的六种产品,现在需要用最少的箱子打包,箱子的底面面积为6*6,高度为H。

解题思路

     简单的暴力贪心算法,对不同的产品有不同的策略,按照从大到小的顺序打包产品,策略如下:

     6*6:1个产品放在1个箱子里

     5*5:1个产品要占用1个箱子,用1*1的箱子可以填充(11个填满1箱)

     4*4:1个产品要占用1个箱子,剩余空间用2*2和1*1的箱子填充(先填充2*2,再填充1*1)

     3*3:4个产品可以填满1个箱子,假如有不满1个箱子的,分情况用1*1和2*2的产品填满

     2*2:9个产品可以填满1个箱子,假如有不满1个箱子的,用1*1的产品填充

     1*1:36个产品可填满一个箱子
#include<bits/stdc++.h>

using namespace std;


int main(){
	int a[7];
	while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6])&& (a[1]+a[2]+a[3]+a[4]+a[5]+a[6])){
	
	
		
		int sum=0;
		//6*6的盒子,每个都刚好独占一个箱子
		sum=a[6]+a[5]+a[4]+(a[3]+3)/4;
		
		if(a[5]>0)
		{
		//5*5的盒子,放进箱子后,每个箱子余下的空间只能放11个1*1的盒子
			a[1]-=a[5]*11;	
		}
		
		if(a[4]>0)
		{
		//4*4的盒子,放进箱子后,每个箱子余下的空间为5个2*2的盒子空间
			int ans=a[4]*5;
		//先把所有2*2的盒子尽可能地放进这些空间
		//若2*2的盒子数比空间少
			if(a[2]<ans)
			{
				
				int temp=ans-a[2];
				a[1]-=temp*4; //用1*1的盒子填充本应放2*2盒子的空间
				a[2]=0;//  //把所有2*2的盒子放进这些空间
				
			}
			//若2*2的盒子数比空间多
			else
			{
				a[2]-=ans;  //则消去已放进空间的部分
			}
		}
		//每4个3*3的盒子完全独占一个箱子
		if(a[3]>0){
			
			int ans=a[3]%4;
		//3*3的盒子不足4个时,都放入一个箱子,剩余空间先放2*2,再放1*1
			if(ans==1){//多出一个3*3,最多可以放置5个2*2,7个1*1 
				a[2]-=5;
				a[1]-=7;
			}
			else  if(ans==2){//多出两个3*3,最多可以放置3个2*2,6个1*1 
				a[2]-=3;
				a[1]-=6;
			}
			else if(ans==3){//多出一个3*3,最多可以放置1个2*2,5个1*1 
				a[2]-=1;
				a[1]-=5;
			}
		}
		//每9个2*2的盒子完全独占一个箱子
		if(a[2]>0)
		{
			 //2*2的盒子不足9个时,都放入一个箱子,剩余空间全放1*1
			sum+=(a[2]+8)/9;
			int ans=a[2]%9;
			a[1]-=(36-ans*4);
		}
		//每36个1*1的盒子完全独占一个箱子
		if(a[1]>0){
			sum+=(a[1]+35)/36;
		}
		
		
		printf("%d\n",sum);
				
		
	}
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值