POJ1847:Tram

点击打开题目链接


Tram

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8817 Accepted: 3207

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

Source


=====================================题目大意=====================================


Zagreb的电车轨道网络由许多的道路交叉口和连接它们的道路组成,进入道路交叉口的电车只能够通过该道路交叉口开关所指向的道

路离开。

如果司机想通过其他道路离开,便需要手动改变开关。

现在告诉你该电车轨道网络中道路交叉口的个数N以及起点道路交叉口的编号A和终点道路交叉口的编号B。

再告诉你每个道路交叉口所连接的道路个数K并给出与其直接相连的其他道路交叉口的编号(其中第一个为开关当前所指向的道路通

往的方向)。

求解从A开往B所需改变道路交叉口开关的最少次数。

 

=====================================算法分析=====================================

 

Dijkstra水题。

 

=======================================代码=======================================

 


 

#include<queue>
#include<cstdio>
#include<cstring>

using namespace std;

const int INF1=0x7f;
const int INF4=0x7f7f7f7f;
const int MAXN=105;

int N,A,B,Dis[MAXN],Edge[MAXN][MAXN];

bool Vis[MAXN];

struct NODE
{
    NODE(int P,int D) { Pt=P;  Dis=D; }
    friend bool operator < (const NODE& A,const NODE& B) { return A.Dis>B.Dis; }
    int Pt,Dis;
};

void Dijkstra()
{
    memset(Vis,0,sizeof(Vis));
    memset(Dis,INF1,sizeof(Dis));
    priority_queue<NODE> q;
    q.push(NODE(A,Dis[A]=0));
    while(!q.empty())
    {
        NODE cur=q.top();  q.pop();
        if(cur.Pt==B) { return; }
        if(Vis[cur.Pt]) { continue; }
        Vis[cur.Pt]=true;
        for(int tmp=1;tmp<=N;++tmp)
        {
            if(Edge[cur.Pt][tmp]<Dis[tmp]-cur.Dis)
            {
                Dis[tmp]=cur.Dis+Edge[cur.Pt][tmp];
                q.push(NODE(tmp,Dis[tmp]));
            }
        }
    }
}

int main()
{
    while(scanf("%d%d%d",&N,&A,&B)==3)
    {
        memset(Edge,INF1,sizeof(Edge));
        for(int i=1;i<=N;++i)
        {
            int K;
            scanf("%d",&K);
            for(int j=1;j<=K;++j)
            {
                int X;
                scanf("%d",&X);
                Edge[i][X]=(j==1?0:1);
            }
        }
        Dijkstra();
        printf("%d\n",Dis[B]==INF4?-1:Dis[B]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值