HDU1159:Common Subsequence

点击打开题目链接

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17608    Accepted Submission(s): 7392


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
      
      
abcfbc abfcab programming contest abcd mnp
 

Sample Output
      
      
4 2 0
 

Source
 

Recommend
Ignatius
 


=====================================题目大意=====================================


求两个给定字符串的最长公共子序列的长度。


=====================================算法分析=====================================


LCS问题,动态规划即可轻松解决(可参加黑书算法导论15.4:最长上升子序列),算法时间复杂度为O(N^2)。

另外还有一个通过将最长公共子序列规划为最长上升子序列的O(N*logN)的算法(点击打开资料链接)。

看起来很牛掰的高效算法,事实上不太可靠,因为其时间复杂度上界为O(N*M*log(N*M)),空间复杂度上界为O(N*M)。

祈神,浩神曰:不可用!遂弃此法以DP辅以滚动数组解之。


=======================================代码=======================================




#include<stdio.h>
#include<string.h>

#define MAX(A,B)  ((A)>(B)?(A):(B))

int F[2][505];

char Str1[505],Str2[505];

int main()
{
	while(scanf("%s%s",Str1,Str2)==2)
	{
		memset(F,0,sizeof(F));
		int M1,M2,Roll=0;
		for(M1=0;Str1[M1];++M1)
		{
			Roll=!Roll;
			for(M2=0;Str2[M2];++M2)
			{
				if(Str1[M1]==Str2[M2]) 
				{
					F[Roll][M2+1]=F[!Roll][M2]+1;
				}
				else
				{ 
					F[Roll][M2+1]=MAX(F[!Roll][M2+1],F[Roll][M2]);
				}
			}
		}
		printf("%d\n",F[Roll][M2]);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值