待续poj1990(树状数组)

http://poj.org/problem?id=1990

MooFest
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 3940Accepted: 1584

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

Source

tle代码。明知tle还是要用我这个2货。。。
#include<iostream>
int v[20001],x[20001];
using namespace std;
int maxn(int a,int b)
{
  return a>b?a:b;
}
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF)
  {
    int i,j;
    memset(v,0,sizeof(v));
    memset(x,0,sizeof(x));
    for(i=0;i<n;i++)
      scanf("%d%d",&v[i],&x[i]);
    double sum=0;
    int diff;
    for(i=0;i<n;i++)
    {
      for(j=i+1;j<n;j++)
      {
        diff=maxn(v[i],v[j]);
        sum+=abs(x[i]-x[j])*diff;
      }
    }
    printf("%.lf\n",sum);
  }
  return 0;
}
//正解是用树状数组,还在学习中,今天就把这题ac,决不食言。
 
看来要食言了,树状数组还不会啊,尽力做。。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值