1poj1477(贪心)

http://poj.org/problem?id=1477

Box of Bricks
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 14471Accepted: 6079

Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
1poj1477(贪心)


Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input

6
5 2 4 1 7 5
0

Sample Output

Set #1
The minimum number of moves is 5.

Source

这题做过3遍了加上这一次。。
高度比平均值小的不动移动步数==sum(所有比平均高度高的墙-平均高度)(---->大水之移花接木)
#include<stdio.h>
int a[60];
int main()
{
      int n,flag=1,average,sum=0;
      while(scanf("%d",&n)!=EOF)
      {
              if(n==0)
                      break;
              int count=0,i;
              sum=0;average=0;
              for(i=0;i<n;i++)
              {
                      scanf("%d",&a[i]);
                      sum+=a[i];
              }
              average=sum/n;
              for(i=0;i<n;i++)
              {
                      if(a[i]>average)
                      {
                              count+=a[i]-average;
                      }
              }
              printf("Set #%d\n",flag++);
              printf("The minimum number of moves is %d.\n\n",count);
      }
      return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值