1033 To Fill or Not to Fill

1033 To Fill or Not to Fill (25 分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
typedef struct MyStruct {
	double price;
	double dis;
}station;
double cost, capacity, dis, Davg, n;
vector<station>s;

bool cmp(station a, station b) {
	return a.dis < b.dis;
}

bool Greedy(double lastprice, double price, double start, double left) {
	double end = start + capacity*Davg, could = start + left*Davg;
	if (could >= dis) {
		double d = could - dis;
		cost -= d / Davg*lastprice;
		return true;
	}
	vector<station> best, need;
	for (int i = 0; i < s.size(); i++)						//搜索区间最优解
		if (s[i].dis > start&&s[i].dis <= end&&s[i].price < price) {
			best.push_back(s[i]);
		}
		else if (s[i].dis > start&&s[i].dis <= end&&s[i].price >= price) {
			need.push_back(s[i]);
		}
		if (best.size()>0) {				//	存在区间最优解
			sort(best.begin(), best.end(), cmp);		//按照距离排序
			cost += ((best[0].dis - start) / Davg - left)*price;
			return Greedy(price, best[0].price, best[0].dis, 0);
		}
		else if (need.size()>0) {		//存在区间可行解
			sort(need.begin(), need.end(), cmp);
			if (start + capacity*Davg >= dis) {
				cost += ((dis - start) / Davg - left)*price;
				return true;
			}
			else {
				cost += (capacity - left)*price;
				left = capacity - (need[need.size() - 1].dis - start) / Davg;    //计算到下一站的剩余量
				return Greedy(price, need[need.size() - 1].price, need[need.size() - 1].dis, left);
			}
		}
		else {								//	不存在区间最优解 
			if (start + capacity*Davg >= dis) {
				cost += ((dis - start) / Davg - left)*price;
				return true;
			}
			else {
				printf("The maximum travel distance = %.2lf\n", end);		//此前判断过end和dis,此处end必定小于dis
				return false;
			}
		}
}

int main() {
	cin >> capacity >> dis >> Davg >> n;
	s = vector<station>(n);
	for (int i = 0; i < n; i++)
		scanf("%lf %lf", &s[i].price, &s[i].dis);
	if (Greedy(0, 0, -capacity*Davg, 0))printf("%.2lf", cost);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值