android导入包的方法

Android Studio 导入SDK Demo

1)进入android studio,点击import project(Eclipse ADT,Gradle,etc),如下图所示:

2)选择AndroidSDK文件夹下的XiaonengChatDemo,并点击 OK,如下图所示:

3)在弹出的Import Project from ADT页面中,填写项目导入后的目标路径,一直点击Next直到Finish,如下图所示:

4)点击Finish后,会弹出Gradle Project info Building界面,如下图所示:

5)Building结束后弹出import-summary.txt,表示导入成功,如下图所示:

6)最后在XiaonengChatUI 的build.gradle 中的defaultConfig 加入minSdkVersion 版本,与主项目中的版本保持一致,并点击Sync Now,如下图所示:

 

第二种方法:

步骤: 
1、导入第三方开源库 
下载资源:http://download.csdn.net/download/lanrenxiaowen/10185999 
在项目里面找到第三方开源库 
这里写图片描述

这时会在项目里面发现多了这个第三方开源库 
这里写图片描述

然后手动修改项目跟目录下settings.gadle 添加include ‘:App’,’:xrecyclerview’如图所示:

include ':App',':xrecyclerview'
  • 1

这里写图片描述

然后在打开App/build.gradle这个文件,添加

dependencies{
compile project(':xrecyclerview')
}
  • 1
  • 2
  • 3

如图: 
这里写图片描述

如果这时候编译还报错的话就在项目xrecyclerview目录下添加一个build.gradle的这个文件,内容如下

apply plugin: 'com.android.library'
version = "1.5.5"
group = "com.jcodecraeer"

def siteUrl = 'https://github.com/jianghejie/XRecyclerView'
def gitUrl = 'https://github.com/jianghejie/XRecyclerView.git'

android {
    compileSdkVersion 26
    buildToolsVersion '26.0.2'

    defaultConfig {
        minSdkVersion 15
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    sourceSets.main{
        jni.srcDirs = []
        jniLibs.srcDir "src/main/libs"
    }
}



dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:26.1.0'
    compile 'com.android.support:recyclerview-v7:26.1.0'
    compile 'com.android.support:design:26.1.0'
}  

task sourcesJar(type: Jar) {
    from android.sourceSets.main.java.srcDirs
    classifier = 'sources'
}

artifacts {
    archives sourcesJar
}
Properties properties = new Properties()
properties.load(project.rootProject.file('local.properties').newDataInputStream())
  •  

最后编译如果还会报错的话 
这时候可能需要修改一下xrecyclerview目录下的AndroidManifest.xml文件有可能存在和你项目中文件有冲突或版本跨度太大导致语法的错误修改一下就OK了。

展开阅读全文

没有更多推荐了,返回首页