uva-489 刽子手游戏

 Hangman Judge 

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.
 
 
 
题目挺简单,但是提交好久才AC,编程能力不行,还需要大量练习。
题目介绍的很复杂,但是大意蛮简单,首先输入一个关键词,接下来输入猜测字母,如果猜的字母在关键词中,关键词的这个字母就算被猜中,猜中全部字母就胜利输出
You win.。如果猜错了记一次失误,7次失误就算输掉,输出You lose.。如果没有把字母全猜中,也没输,输出You chickened out.。我一度非常疑惑chicken out是神马意思,查了一下有道翻译,翻译成了“鸡了”,真心成吉思汗。
#include <cstdio>
#include <cctype>
#include <cstring>
using namespace std;

int alpha[26];//字母哈希,0表示关键词中无此字母,1表示关键词中有此字母且未被猜中,-1表示关键词中有此字母且被猜中了
const int death=7;

int alpha_to_int(char c){
	return islower(c)?(c-'a'):(c-'A');
}//把字母换算成对应数字
int main()
{
	int round;
	while(scanf("%d",&round)){
		if(round==-1) break;
		char str1[1000],str2[1000];//
		scanf("%s%s",str1,str2);
		memset(alpha,0,sizeof(alpha));
		int len1=strlen(str1),len2=strlen(str2);
		int alpha_num=0;//统计共有多少个单词出现
		for(int i=0;i<len1;i++){//
			int t=alpha_to_int(str1[i]);
			if(alpha[t]==0){
				alpha_num++;
				alpha[t]=1;//关键词中有此字母
			}
		}
		
		int lose=0,ftime=0,win=0,rtime=0;//lose和win是标记,ftime是错误次数,rtime是不计重复的正确次数(同样单词猜中两次不算)
		for(int i=0;i<len2;i++){
			int t=alpha_to_int(str2[i]);
			if(alpha[t]==0) ftime++;
			if(ftime==death){//失误次数到了7次
				lose=1;
				break;
			}
			if(alpha[t]==1){
				alpha[t]=-1;
				rtime++;
			}
			if(rtime==alpha_num){//正确次数等于单词出现数
				win=1;
				break;
			}
		}
		
		printf("Round %d\n",round);
		if(lose) printf("You lose.\n");
		else if(win) printf("You win.\n");
		else printf("You chickened out.\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值