ubuntu14.04下安装ffmpeg

一、安装各种依赖包

1、yasm(libx264需要依赖yasm)

      sudo apt-get install yasm

2、libx264

      sudo apt-get install libx264-dev

3、libfaac

      sudo apt-get install libfaac-dev

4、libmp3lame

      sudo apt-get install libmp3lame-dev

5、libtheora

      sudo apt-get install libtheora-dev

6、libvorbis

      sudo apt-get install libvorbis-dev

7、libxvid

      sudo apt-get install libxvidcore-dev

8、libxext

      sudo apt-get install libxext-dev

9、libxfixes

      sudo apt-get install libxfixes-dev

 

二、下载FFmpeg安装包

官网下载最新版本的FFmpeg配置的时候不成功,最终使用的是FFmpeg 2.4.13 "Fresnel",下载网址:http://www.ffmpeg.org/olddownload.html

1、解压

      tar -xjvf ffmpeg-2.4.13.tar.bz2

2、配置

      cd ffmpeg-2.4.13/

      ./configure --prefix=/usr/local/ffmpeg --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libmp3lame --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab --enable-libvorbis

3、编译安装

      make

      make install

4、将ffmpeg-2.4.13文件夹下生成的ffmpeg可执行文件拷贝到/usr/bin/目录下

     sudo cp ffmpeg ../usr/bin/

三、运行

运行格式:ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}

如要将yuv文件转换为png,则

      ffmpeg -pix_fmt nv12 -s 1280x720 -i srcPic.yuv -y desPic.png

 

文章参考了http://blog.csdn.net/redstarofsleep/article/details/45092145,感谢博主。

 
发布了11 篇原创文章 · 获赞 14 · 访问量 3万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览