hdoj 4135 Co-prime<直接模拟||队列技巧--容斥原理>

感觉会超时-.-谁知道过了----


Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3480    Accepted Submission(s): 1375


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source


百度百科:

计数时,必须注意没有重复,没有遗漏。为了使重叠部分不被重复计算,人们研究出一种新的计数方法,这种方法的基本思想是:先不考虑重叠的情况,把包含于某内容中的所有对象的数目先计算出来,然后再把计数时重复计算的数目排斥出去,使得计算的结果既无遗漏又无重复,这种计数的方法称为容斥原理。




模拟代码:

#include<cstdio>
#include<cmath>
__int64 a,b,s,ss;
int zhi[50],kp,nn;
void zh(int xx)
{
	kp=0;
	for (int i=2;i<=sqrt(xx);i++)
	{
		if (xx%i==0)
		{
			zhi[kp++]=i;
			while (xx%i==0)
			xx/=i;
		}
	}
	if (xx!=1)
	zhi[kp++]=xx;
}
void bfs(int n,int ge,int he,int pp,__int64 kkk)
{
	if (ge==pp)
	{
		ss+=kkk/he;
		return;
	}
	if (n==kp)
	return;
	bfs(n+1,ge+1,he*zhi[n],pp,kkk);
	bfs(n+1,ge,he,pp,kkk);
}
__int64 ji(int n,__int64 klp)
{
	ss=0;
	bfs(0,0,1,n,klp);
	return ss;
}
int main()
{
	int t;scanf("%d",&t);
	for (int ca=1;ca<=t;ca++)
	{
		scanf("%I64d%I64d%I64d",&a,&b,&nn);
		zh(nn);
		int lp=-1;s=0;
		for (int i=1;i<=kp;i++)
		{
			lp*=-1;
			s+=lp*ji(i,b);
		}
		lp=1;
		for (int i=1;i<=kp;i++)
		{
			lp*=-1;
			s+=lp*ji(i,a-1);
		}
		s=b-a+1-s;
		printf("Case #%d: %I64d\n",ca,s);
	}
	return 0;
}

队列技巧代码:

#include<cstdio>
#include<cmath>
__int64 a,b,s,ss;
int zhi[50],kp,nn;
void zh(int xx)
{
	kp=0;
	for (int i=2;i<=sqrt(xx);i++)
	{
		if (xx%i==0)
		{
			zhi[kp++]=i;
			while (xx%i==0)
			xx/=i;
		}
	}
	if (xx!=1)
	zhi[kp++]=xx;
}
__int64 suan(__int64 n)
{
	ss=0;
	int shu[100010],ge=0;
	shu[ge++]=-1;
	for (int i=0;i<kp;i++)
	{
		int t=ge;
		for (int j=0;j<t;j++)
		shu[ge++]=shu[j]*zhi[i]*(-1);
	}
	for (int i=1;i<ge;i++)
	ss+=n/shu[i];
	return ss;
}
int main()
{
	int t;scanf("%d",&t);
	for (int ca=1;ca<=t;ca++)
	{
		scanf("%I64d%I64d%I64d",&a,&b,&nn);
		zh(nn);
		s=suan(b)-suan(a-1);
		s=b-a+1-s;
		printf("Case #%d: %I64d\n",ca,s);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值