hdoj 1159 && nyoj 36【DP - LCS】

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33694    Accepted Submission(s): 15330


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 

Source




【转】百度文库ppt

引进一个二维数组C

C[i,j]记录XiYjLCS的长度

  如果我们是按行、列的序号从小到大地进行递推计算

(从第1行开始计算:C[1,1]、C[1,2]、。。。C[1,n],

再算C[2,1]、C[2,2]、。。。C[2,n],。。。。。。。。最后计算

C[m,1]、C[m,2]、。。。C[m,n],最后算出的C[m,n]即

为LCS(X , Y)的长度。)那么在计算C[i,j]之前,

C[i-1,j-1], C[i-1,j]C[i,j-1]均已计算出来。此时

根据X[i]=Y[j]还是X[i]¹Y[j],就可以计算出C[i,j]

X[i]=Y[j],则执行C[i,j]←C[i-1,j-1]+1

X[i]¹Y[j]进行下述判断:

C[i-1,j]≥C[i,j-1]C[i,j]C[i-1,j]

否则C[i,j]C[i,j-1]


不是很明白代码2与代码1的区别--



代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[520],b[520];
int dp[520][520];
int main()
{

    while (~scanf("%s",a))
    {
        scanf("%s",b);
        int n=strlen(a);
        int m=strlen(b);
        memset(dp,0,sizeof(dp));
        /* for (int i=0;i<m;i++)
       if (a[0]==b[i])
        dp[0][i]=1;
        for (int i=0;i<n;i++)
        if (b[0]==a[i])
        dp[i][0]=1;*/
        for (int i=1;i<=n;i++)
        for (int j=1;j<=m;j++)
        if (a[i-1]==b[j-1])
        dp[i][j]=dp[i-1][j-1]+1;
        else
        dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        printf("%d\n",dp[n][m]);

    }
    return 0;
}



WA代码2:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[520],b[520];
int dp[520][520];
int main()
{

    while (~scanf("%s",a))
    {
        scanf("%s",b);
        int n=strlen(a);
        int m=strlen(b);
        memset(dp,0,sizeof(dp));
         for (int i=0;i<m;i++)
         if (a[0]==b[i])
         dp[0][i]=1;
         for (int i=0;i<n;i++)
         if (b[0]==a[i])
         dp[i][0]=1;
        for (int i=1;i<n;i++)
        for (int j=1;j<m;j++)
        if (a[i]==b[j])
        dp[i][j]=dp[i-1][j-1]+1;
        else
        dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        printf("%d\n",dp[n-1][m-1]);

    }
    return 0;
}


最长公共子序列

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
咱们就不拐弯抹角了,如题,需要你做的就是写一个程序,得出最长公共子序列。
tip:最长公共子序列也称作最长公共子串(不要求连续),英文缩写为LCS(Longest Common Subsequence)。其定义是,一个序列 S ,如果分别是两个或多个已知序列的子序列,且是所有符合此条件序列中最长的,则 S 称为已知序列的最长公共子序列。
输入
第一行给出一个整数N(0<N<100)表示待测数据组数
接下来每组数据两行,分别为待测的两组字符串。每个字符串长度不大于1000.
输出
每组测试数据输出一个整数,表示最长公共子序列长度。每组结果占一行。
样例输入
2
asdf
adfsd
123abc
abc123abc
样例输出
3
6
来源
经典
上传者
hzyqazasdf


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值