【PAT甲级】 1007 Maximum Subsequence Sum

【PAT甲级】 1007 Maximum Subsequence Sum

原题

Given a sequence of K integers {N1,N2,…,Nk}. A continuous subsequence is defined to be {Ni,Ni+1,…,Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input 1:

    10
    -10 1 2 3 4 -5 -23 3 7 -21

Sample Output 1:

    10 1 4

思路

题目要求

给定一组整数序列,求其子序列的最大和,并给出子序列的第一个数和最后一个数。

题目分析

  1. 输出最后无空格;
  2. 输出为一行;

易错点

  1. 不是开头和结尾在原序列中所处的位置,而是给数(如果仅看输入输出可能会有歧义);
  2. 如果最大值是负数,直接输出0;

参考代码如下

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int n;
	scanf("%d",&n);
	// int aa[n]不能用因为n是变量,但如果直接用10000会产生大量空闲空间
	vector<int> v(n);//这里要注意不要写成v[n]
	int left=0,right=n-1;
	int lleft=0;
	int sum=-1,max=0;
	for(int i=0;i<n;i++){//也可以输入和判断分开,分别用一个for循环
		scanf("%d",&v[i]);
		max+=v[i];
		if(max<0){//要先判断小于0的情况
			lleft=i+1;
			max=0;
		}
		else if(max>sum){
			sum=max;
			right=i;
			left=lleft;
		}
	}
	if(sum<0) sum=0;//题目要求
	printf("%d %d %d",sum,v[left],v[right]);
}


  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值