POJ2570 Fiber Network floyd+位运算

floyd+位运算。用spfa应该也是可以的,但是没有必要,这里floyd可以解决了。关键是,代码少
太粗心了,先是忘记加位运算头文件送了一次ce,然后又是忘记多输出一个换行又送一个pe。。。。
Fiber Network

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 2389

 

Accepted: 1107

Description

Several startup companies have decided to build a better Internet, called the "FiberNet". They have already installed many nodes that act as routers all around the world. Unfortunately, they started to quarrel about the connecting lines, and ended up with every company laying its own set of cables between some of the nodes.
Now, service providers, who want to send data from node A to node B are curious, which company is able to provide the necessary connections. Help the providers by answering their queries.

Input

The input contains several test cases. Each test case starts with the number of nodes of the network n. Input is terminated by n=0. Otherwise, 1<=n<=200. Nodes have the numbers 1, ..., n. Then follows a list of connections. Every connection starts with two numbers A, B. The list of connections is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the unidirectional connection, respectively. For every connection, the two nodes are followed by the companies that have a connection from node A to node B. A company is identified by a lower-case letter. The set of companies having a connection is just a word composed of lower-case letters.
After the list of connections, each test case is completed by a list of queries. Each query consists of two numbers A, B. The list (and with it the test case) is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the query. You may assume that no connection and no query contains identical start and end nodes.

Output

For each query in every test case generate a line containing the identifiers of all the companies, that can route data packages on their own connections from the start node to the end node of the query. If there are no companies, output "-" instead. Output a blank line after each test case.

Sample Input

3
1 2 abc
2 3 ad
1 3 b
3 1 de
0 0
1 3
2 1
3 2
0 0
2
1 2 z
0 0
1 2
2 1
0 0
0

Sample Output

ab
d
-

z
-
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<bitset>
using namespace std;
#define MAXN 220

int a[MAXN][MAXN];
int n;

void floyd()
{
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(k==i && k==j)
					continue;
				a[i][j]|=a[i][k]&a[k][j];
			}
		}
	}
}

void init()
{
	memset(a,0,sizeof(a));
	int x,y;
	string s;
	while(cin>>x>>y && x+y!=0)
	{
		cin>>s;
		for(int i=0;i<s.length();i++)
			a[x][y]|=1<<(s[i]-'a');
	}
}

void solve()
{
	floyd();
	int x,y;
	while(cin>>x>>y && x+y!=0)
	{
		int temp=a[x][y];
		bool flag=true;
		for(int i=1;i<=26;i++)
		{
			if((temp>>(i-1)&1)==1)
			{
				flag=false;
				cout<<(char)(i+'a'-1);
			}
		}
		if(flag)
			cout<<"-";
		cout<<endl;
	}
	cout<<endl;
}

int main()
{
	while(cin>>n && n)
	{
		init();
		solve();
	}
	return 0;
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值