BellmanFord: Til the cows come home

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20995 Accepted: 6994

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

#define INF 99999999
int w[20010][20010];
int e[40010];
int u[20010];
int v[20010];
int d[20010];

int t, n;

int main(){
    int i, j, k, m, ww, x, y;
    int z;
    int cnt;
    while(cin >> t >> n){
        cnt = 0;
        memset(v, 0, sizeof(v));
        memset(d, 0, sizeof(d));
        for(i = 1; i <= n; i ++)        //预处理出发点到i点的距离
            d[i] = (i == 1 ? 0 : INF);
        for(i = 0; i < t; i ++){        //输入的时候不用注意有重复的边
            scanf("%d %d", &z, &y);
            scanf("%d", &w[z][y]);
            e[++cnt] = w[z][y];
            u[cnt] = z;
            v[cnt] = y;
            e[++cnt] = w[z][y];
            u[cnt] = y;
            v[cnt] = z;
        }
        for( k = 0; k < n - 1; k ++){
            for(i = 1; i <= cnt; i ++){
                x = u[i];
                y = v[i];
                if(d[x] < INF)
                    if(d[y] > d[x] + e[i])
                        d[y] = d[x] + e[i];
            }
        }
        cout << d[n] << endl;
    }
    return 0;
}

若使用fifo队列优化,则是
#define INF 1 << 31 - 1

int t, n;
int cnt;
int lastshow[40010];
int d[40010];

struct edge{
    int to;
    int wei;
    int next;
}e[40010];

void insert(int a, int b, int c){
    cnt ++;
    e[cnt].to = b;
    e[cnt].next = lastshow[a];
    e[cnt].wei = c;
    lastshow[a] = cnt;
}

queue<int> q;
bool inq[40010];
void bellmanford(){
    memset(inq, false, sizeof(inq));
    while(!q.empty()){
        q.pop();
    }
    q.push(1); //注意此处push的是一个起点
    while(!q.empty()){
        int x = q.front();
        q.pop();
        inq[x] = false;
        for(int i = lastshow[x]; i != -1; i = e[i].next){
            if(d[e[i].to] > d[x] + e[i].wei){
                d[e[i].to] = d[x] + e[i].wei;
                if(!inq[e[i].to]){
                    inq[e[i].to] = true;
                    q.push(e[i].to);
                }
            }
        }
    }
}

int main(){
    int i, j, k, m, ww, x, y;
    int z;
    int cnt;
    while(cin >> t >> n){
        cnt = 0;
        memset(lastshow, -1, sizeof(lastshow));
        for(i = 1; i <= n; i ++)        //预处理出发点到i点的距离
            d[i] = (i == 1 ? 0 : INF);
        for(i = 0; i < t; i ++){        //输入的时候不用注意有重复的边
            int a, b, c;
            scanf("%d %d %d", &a, &b, &c);
            insert(a, b, c);
            insert(b, a, c);
        }
        bellmanford();
        cout << d[n] << endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值