hdu 3374 String Problem 【kmp+最小(大)表示法】

String Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1653    Accepted Submission(s): 747


Problem Description
Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
 

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Sample Input
  
  
abcder aaaaaa ababab
 

Sample Output
  
  
1 1 6 1 1 6 1 6 1 3 2 3

此题可用最小(大)表示法求出first和last string,用kmp的next数组求出最小循环节,这出现次数为len/最小循环节,f此题irst出现次数和last出现次数相等。

可以看一下kmp算法:http://www.cnblogs.com/dolphin0520/archive/2011/08/24/2151846.html 

 kmp求最小循环节:http://blog.sina.com.cn/s/blog_7981299401012xl0.html 

 最小表示法:http://blog.csdn.net/cclsoft/article/details/5467743 

代码示例:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define maxh 10000000+100
using namespace std;
char str[maxh+maxh],strs[maxh];
int next[maxh];
int minsign(int m)
{
    int i,j,l;
    i=0,j=1;
    while(i<m&&j<m)
    {
        for(l=0;l<m;l++)
        if(str[(i+l)%m]!=str[(j+l)%m])break;
        if(l>m)break;
        if(str[(i+l)%m]>str[(j+l)%m]) 
        i=i+l+1;
        else
        j=j+l+1;
        if(i==j)j=i+1;
    }
    if(i<j)return i;
    return j;
}
int maxsign(int m)
{
    int i,j,l;
    i=0; j=1;
    while(i<m&&j<m)
    {
        for(l=0;l<m;l++) 
            if(str[(i+l)%m]!=str[(j+l)%m]) break;
        if(l>m) break;
        if(str[(i+l)%m]<str[(j+l)%m])
            i=i+l+1;
        else
            j=j+l+1;
        if(i==j) j=i+1;
    }
    if(i<j) return i;
    return j;
}
void bmf(int m) 
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<m)
    {
        if(j==-1||str[i]==str[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
        {
            j=next[j];
        }
    }
}    
int main()
{  
    while(~scanf("%s",str))
    {
        int L=strlen(str);
        int l1=minsign(L);
        int l2=maxsign(L);
        bmf(L);
        int l=L-next[L];
        int ans=L%l?1:L/l;
        printf("%d %d %d %d\n",l1+1,ans,l2+1,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值