Could not find com.android.tools.build:gradle:3.0.1

版权声明: https://blog.csdn.net/lfdfhl/article/details/81101598

自定义View系列教程00–推翻自己和过往,重学自定义View
自定义View系列教程01–常用工具介绍
自定义View系列教程02–onMeasure源码详尽分析
自定义View系列教程03–onLayout源码详尽分析
自定义View系列教程04–Draw源码分析及其实践
自定义View系列教程05–示例分析
自定义View系列教程06–详解View的Touch事件处理
自定义View系列教程07–详解ViewGroup分发Touch事件
自定义View系列教程08–滑动冲突的产生及其处理


探索Android软键盘的疑难杂症
深入探讨Android异步精髓Handler
详解Android主流框架不可或缺的基石
站在源码的肩膀上全解Scroller工作机制


Android多分辨率适配框架(1)— 核心基础
Android多分辨率适配框架(2)— 原理剖析
Android多分辨率适配框架(3)— 使用指南


版权声明


Android Studio 升级后报错:

Could not find com.android.tools.build:gradle:3.0.1

在此介绍一种简单、粗暴、有效的解决办法。

第一步

打开项目的build.gradle。再次强调:是项目的build.gradle而不是Module的build.gradle

第二步

在build.gradle文件中的buildscript的repositories添加google( ),代码如下:

buildscript {
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

第三步

在build.gradle文件中的allprojects的repositories添加google( ),代码如下:

allprojects {
    repositories {
        google()
        jcenter()
    }
}

第四步

更新,OK,收工。

阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页