hdoj_3336Count the string(KMP)

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2808    Accepted Submission(s): 1308


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6

做的几个题都利用了next数组的性质,好强大的看毛片算法

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#pragma warning(disable : 4996)
#define MAX 200005
int n;
char text[MAX];
int Next[MAX];
void get_next()
{
	Next[1] = 0;
	int i, j = 0;
	for(i = 2; i <= n; i++)
	{
		while(j > 0 && text[j+1] != text[i])
		{
			j = Next[j];
		}
		if(text[j+1] == text[i])
		{
			j += 1;
		}
		Next[i] = j;
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	int sum, t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		scanf("%s", text + 1);
		get_next();
		sum = 0;
		/*for(int i = 1; i <= n; i++)
		{
			cout << Next[i] << " ";
		}
		cout << endl;*/
		for(int i = 1; i <= n; i++)
		{
			int j = i;
			while (j != 0)
			{
				sum++;
				j = Next[j];
			}
		}
		printf("%d\n", sum % 10007);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

N3verL4nd

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值