并查集_1118 Birds in Forest

1118 Birds in Forest (25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

思路

题目指出,出现在同一张图片中的鸟则表示在一棵树上,那么每一行表示出现在同一张图片中鸟的编号,那么要求判断一共多少棵树以及多少只鸟,并且任意给出两个鸟的编号,判断是否在同一颗树上面

并查集的思路为:以每一棵树中第一个出现的鸟为父节点,后面所有的鸟为子节点,做出一棵树,并且更新per数组,那么这样做过所有照片,则所有的鸟就做出了一棵树,判断每一只鸟对应的per数组是否等于其编号,如果相等,则表示它及它的子节点在同一颗树上,这样计算树的个数即可

程序

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <set>
#include <queue>
#include <cmath>
#include <map>
#define INF 0x3f3f3f3f

using namespace std;
const int maxn = 1e4+5;
int n,belong[maxn];
set<int> all;
int per[maxn];

int Find(int x)
{
    return x == per[x]?x:per[x] = Find(per[x]);
}
void Init()
{
    for(int i = 1;i < maxn;i ++)
        per[i] = i;
}
void Union(int x,int y)
{
    x = Find(x);
    y = Find(y);
    if(x != y)
        per[y] = x;
}

int main()
{
    Init();
    int num,x,y,head;
    scanf("%d",&n);
    int index = 1;
    for(int i =0 ;i < n;i ++)
    {
        scanf("%d",&num);
        scanf("%d",&head);
        all.insert(head);
        for(int j = 0;j < num-1;j ++)
        {
            scanf("%d",&y);
            Union(head,y);
            all.insert(y);
        }
    }
    int ans = 0;
    for(int i = 1;i <= all.size();i ++)
        if(Find(i) == i)
            ans ++;
    printf("%d %d\n",ans,all.size());
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&x,&y);
        if(Find(x) == Find(y))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

参考博客

https://blog.csdn.net/qq_38677814/article/details/82082258 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值