POJ 2151 Check the difficulty of problems

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6653 Accepted: 2889

Description

Organizing a programming   contest (竞赛)  is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of   preliminary (初步的)  contest, the organizer can   estimate (估计)  the   probability (可能性)  that a certain team can successfully solve a certain problem.

Given the number of   contest (竞赛)  problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also   assume (承担)  that team i solves problem j with the   probability (可能性)  Pij (1 <= i <= T, 1<= j <= M). Well, can you   calculate (计算)  the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The   input (投入)  consists of several test cases. The first line of each test case contains three   integers (整数)  M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0   indicates (表明)  the end of input, and should not be processed.

Output

For each test case, please   output (输出)  the answer in a separate line. The result should be rounded to three   digits (数字)  after the   decimal (小数)  point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

数学真的是个硬伤啊,当时读完题直接就是蒙的,想了半天还是去看了大神的博客,概率DP以前就没接触过,又找到了新的学习方向了。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>

using namespace std;

double dp[1010][55][55];
double s[1010][55];
double p[1010][55];

int main()
{
    int m,n,t;
    while(cin>>m>>t>>n)
    {
        if(m==0&&t==0&&n==0) break;
        for(int i=1;i<=t;i++)
        for(int j=1;j<=m;j++) scanf("%lf",&p[i][j]);
        for(int i=1;i<=t;i++)
        {
            dp[i][0][0]=1;
            for(int j=1;j<=m;j++)dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);
            for(int j=1;j<=m;j++)
            for(int k=1;k<=j;k++) dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
            s[i][0]=dp[i][m][0];
            for(int k=1;k<=m;k++)s[i][k]=s[i][k-1]+dp[i][m][k];
        }
        double P1=1;
        double P2=1;
        for(int i=1;i<=t;i++)
        {
            P1*=(1-s[i][0]);
            P2*=(s[i][n-1]-s[i][0]);
        }
        printf("%.3f\n",P1-P2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值